ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17024. Типовые варианты

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно.

Определите количество троек последовательности, в которых только одно число оканчивается на 0, а сумма элементов тройки меньше максимального элемента последовательности.

В ответе запишите количество найденных троек, затем максимальную из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента

with open('1724.txt') as f:
    data = list(map(int, f))

mx = max(data)


def f1(nums):
    return sum(num % 10 == 0 for num in nums) == 1


def f2(nums):
    return sum(nums) < mx


ans = []
for elements in zip(data, data[1:], data[2:]):
    if f1(elements) and f2(elements):
        ans.append(sum(elements))

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие