ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17025. Типовые варианты

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно.

Определите количество пар последовательности, в которых сумма чисел пары равна максимальному чётному элементу последовательности.

В ответе запишите количество найденных пар, затем максимальную из сумм квадратов элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента

with open('1725.txt') as f:
    data = list(map(int, f))

max_even = max(i for i in data if i % 2 == 0)


def f(nums):
    return sum(nums) == max_even



ans = []
for elements in zip(data, data[1:]):
    if f(elements):
        ans.append((elements[0]**2 + elements[1]**2))

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие