ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17023. Типовые варианты

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от -100 000 до 100 000 включительно.

Определите количество троек последовательности, в которых хотя бы одно из чисел является четырёхзначным, а сумма элементов тройки больше максимального элемента последовательности, оканчивающегося на 90.

В ответе запишите количество найденных троек, затем минимальную из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента

with open('1723.txt') as f:
    data = list(map(int, f))

max_90 = max(i for i in data if abs(i) % 100 == 90)


def f1(nums):
    return sum(1000 <= abs(num) <= 9999 for num in nums) >= 1

def f2(nums):
    return sum(nums) > max_90


ans = []
for elements in zip(data, data[1:], data[2:]):
    if f1(elements) and f2(elements):
        ans.append(sum(elements))

print(len(ans), min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие