ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17020. Типовые варианты

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно.

Определите количество пар последовательности, в которых остаток от деления хотя бы одного из элементов на 30 равен минимальному элементу последовательности.

В ответе запишите количество найденных пар, затем минимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента

with open('1720.txt') as f:
    data = list(map(int, f))

mn = min(data)

def f(nums):
    return any(num %30 ==mn for num in nums)


ans = []
for elements in zip(data, data[1:]):
    if f(elements):
        ans.append(sum(elements))

print(len(ans), min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие