ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15100. Типовая задача

На числовой прямой даны два отрезка: B = [14; 20] и C = [15; 27].

Укажите наименьшую возможную длину такого отрезка A, что логическое выражение ¬(x ∈ A) → ((x ∈ B) ≡ (x ∈ C)) истинно (т.е. принимает значение 1) при любом значении переменной х.

from itertools import combinations

def f(x):
    B = 14 <= x <= 20
    C = 15 <= x <= 27
    A = A1 <= x <= A2
    return (not A) <= (B == C)


line_A = sorted([14, 20, 15, 27])
line_x = [14.5, 20.5, 15.5]

ans = []
for A1, A2 in combinations(line_A, 2):
    if all(f(x) for x in line_x):
        ans.append(A2 - A1)

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие