ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15040. Основная волна 2025

Для какого наименьшего целого неотрицательного числа A выражение (x · y > A) ∨ (x > y) ∨ (11 >x) тождественно истинно, т.е. принимает значение 1 при любых целых положительных x и y?

def f(x, y, A):
    return (x * y > A) or (x > y) or (11 > x)


for A in range(0, 1000)[::-1]:
    if all(f(x, y, A) for x in range(1, 50) for y in range(1, 50)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие