ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15005. Досрочная волна

Обозначим через m & n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14 & 5 = 11102 & 01012 = 01002 = 4.

Для какого наименьшего неотрицательного целого числа А логическое выражение x & 39 = 0 ∨ (x & 11 = 0 → ¬(x & А = 0)) истинно (т.е. принимает значение 1) при любом неотрицательном целом значении переменной х?

def f(x, A):
    return (x & 39 == 0) or ((x & 11 == 0) <= (not (x & A == 0)))


for A in range(0, 100):
    if all(f(x, A) for x in range(0, 100)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие