ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15003. ЕГКР

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

Для какого наибольшего натурального числа А логическое выражение ¬ДЕЛ(x, А) → (ДЕЛ(x, 28) → ¬ДЕЛ(x, 49)) истинно (т.е. принимает значение 1) при любом натуральном значении переменной х?

def f(x, A):
    return (x % A != 0) <= ((x % 28 == 0) <= (x % 49 != 0))


for A in range(1, 200)[::-1]:
    if all(f(x, A) for x in range(1, 1000)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие