ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 25022. ЕГКР

Напишите программу, которая перебирает целые числа, большие 1 350 050, в порядке возрастания и ищет среди них такие, у которых есть натуральный делитель, оканчивающийся на 11 и не равный ни самому числу, ни числу 11.

В ответе запишите в первом столбце таблицы первые пять найденных чисел в порядке возрастания, а во втором столбце — для каждого числа соответствующий минимальный делитель, оканчивающийся на 11, не равный ни самому числу, ни числу 11.

cnt = 0
for num in range(1_350_050, 10 ** 20):
    for dev in range(2, num):
        if num % dev == 0 and dev != 11 and dev % 100 == 11:
            print(num, dev)
            cnt += 1
    if cnt == 5:
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие