ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 25000. Основная волна

Пусть М – сумма минимального и максимального натуральных делителей целого числа, не считая единицы и самого числа. Если таких делителей нет, то считаем значение М равным нулю.

Напишите программу, которая перебирает целые числа, больше 700 000, в порядке возрастания и ищет среди них такие, для которых М оканчивается на 4.

В ответе запишите в первом столбце таблицы первые пять найденных чисел в порядке возрастания, а во втором столбце – соответствующие им значения М.
Например, для числа 20 М = 2 + 10 = 12.

from math import isqrt

def f(num):
    res = set()
    for i in range(2, isqrt(num) + 1):
        if num % i == 0:
            res |= {i, num // i}

    if len(res):
        summ = min(res) + max(res)
        if summ % 10 == 4:
            return summ
    return 0


cnt = 0
for i in range(700_001, 10 ** 20):
    if M := f(i):
        print(i, M)
        cnt += 1
        if cnt == 5:
            break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие