ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17021. Типовые варианты

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно.

Определите количество пар последовательности, в которых сумма остатков от деления обоих элементов на 44 равна минимальному элементу последовательности.

В ответе запишите количество найденных пар, затем минимальный модуль разности элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента

with open('1721.txt') as f:
    data = list(map(int, f))

mn = min(data)


def f(nums):
    r1 = nums[0] % 44
    r2 = nums[1] % 44
    return r1 + r2 == mn


ans = []
for elements in zip(data, data[1:]):
    if f(elements):
        ans.append(abs(elements[0] - elements[1]))

print(len(ans), min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие