ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 10209. Авторская задача

Два узла, находящиеся в разных подсетях, имеют IP-адреса 192.168.34.17 и 192.168.45.91. Известно, что в масках обеих подсетей содержится одинаковое количество единиц.

Определите наименьшее возможное количество единиц в масках этих подсетей.

В ответе укажите только число.

from ipaddress import ip_network, ip_address

ip1 = ip_address('192.168.34.17')
ip2 = ip_address('192.168.45.91')

for mask in range(16, 31):
    net_1 = ip_network(f'{ip1}/{mask}', strict=False)
    net_2 = ip_network(f'{ip2}/{mask}', strict=False)

    if (net_1 != net_2
        and ip1 in net_1.hosts() and ip2 in net_2.hosts()):
        print(mask)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие