ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 10206. Авторская задача

Два узла, находящиеся в одной сети, имеют IP-адреса 127.0.1.65 и 127.0.1.101.

Укажите наименьшее возможное количество адресов в этой сети.

from ipaddress import ip_network, ip_address
ip_1 = ip_address('127.0.1.65')
ip_2 = ip_address('127.0.1.101')

for mask in range(31)[::-1]:
    net_1 = ip_network(f'{ip_1}/{mask}', strict=False)
    net_2 = ip_network(f'{ip_2}/{mask}', strict=False)

    if net_1 == net_2 and ip_1 in net_1.hosts() and ip_2  in net_1.hosts():
        print(net_1.num_addresses)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие