ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 10202. Авторская задача

Сеть, в которой содержится узел с IP-адресом 240.224.A.60, задана маской сети 255.255.255.128, где A — некоторое допустимое для записи IP-адреса число.

Определите минимальное значение A, для которого для всех IP-адресов этой сети в двоичной записи IP-адреса суммарное количество единиц будет больше 13.

В ответе укажите только число.

from ipaddress import ip_network

mask = '255.255.255.128'

for A in range(256):
    net = ip_network(f'240.224.{A}.60/{mask}', False)
    if all(f'{int(ip):032b}'.count('1') > 13 for ip in net):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие