ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 10200. Авторская задача

Для узла с IP-адресом 192.168.24.72  адрес сети равен 192.168.24.64.

Определите наименьшее возможное количество единиц в последних двух байтах маски.

В ответе укажите только число.

from ipaddress import ip_interface, ip_address

ip_net = ip_address('192.168.24.64')
ip_host = ip_address('192.168.24.72')

bit_mask = []

for mask in range(17, 31):
    net = ip_interface(f'{ip_net}/{mask}')
    if ip_host in net.network.hosts() and net.network.network_address == ip_net:
        bit_mask.append(f'{int(net.netmask):032b}'[16:])



print(min(bit_mask).count("1"))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие