ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 5105. Типовая задача

Автомат получает на вход четырёхзначное число K. По этому числу строится новое число L по следующим правилам:

  1. Вычисляется число S — сумма всех цифр числа K.
  2. Вычисляется число M, равное значению максимальной цифры в записи числа K.
  3. Вычисляется число N, равное значению минимальной цифры в записи числа K.
  4. Вычисляется число P1: P1 = S — M.
  5. Вычисляется число P2: P2 = S — N.
  6. Новое число L получается в результате записи рядом без пробелов чисел P1 и P2 таким образом, чтобы они следовали слева направо в неубывающем порядке

Пример. Исходное число K = 6241.
Сумма его цифр S = 6 + 2 + 4 + 1 = 13.
M = 6.
N = 1.
P1 = 13 — 6 = 7.
P2 = 13 — 1 = 12.
Результат: L = 712

Укажите наименьшее число K, при обработке которого автомат выдаст число L = 1318.

for K in range(1_000, 10_000):
    K = list(map(int, str(K)))
    S = sum(K)
    M = max(K)
    N = min(K)
    P_1 = S - M
    P_2 = S - N
    if P_1 >= P_2:
        L = str(P_2) + str(P_1)

    else:
        L = str(P_1) + str(P_2)
    if L == '1318':
        print(K)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие