ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 26024. ЕГКР

Менеджеры интернет-магазина составляют рейтинговый список новых моделей смартфонов по данным о продолжительности автономной работы устройства в режиме ожидания и в активном режиме использования. У каждой модели известны оба показателя. Для объективности бренды и марки устройств скрыты, в списке все смартфоны пронумерованы начиная с единицы.
Алгоритм формирования рейтинга выглядит следующим образом:
— все 2N чисел, обозначающих продолжительности работы в режиме ожидания и в режиме активного использования для N устройств, располагаются по возрастанию;
— если наименьший показатель соответствует продолжительности работы в режиме ожидания, устройство занимает первое свободное место от начала рейтинга;
— если наименьший показатель относится к продолжительности работы в активном режиме использования смартфона, устройство занимает первое свободное место от конца рейтинга;
— показатели устройств, ранее включённых в рейтинговый список, игнорируются.

Определите порядковый номер смартфона, чей рейтинг будет определён последним, и количество устройств, занявших позиции ниже него.
Запишите в ответе два натуральных числа: сначала номер последнего устройства, для которого будет определено его место в рейтинге, затем количество устройств, которые займут в рейтинге более низкие места.

Входные данные

В первой строке входного файла находится натуральное число N (N ≤ 1000) — количество смартфонов. Следующие N строк содержат пары чисел, обозначающих соответственно продолжительность работы устройства в режиме ожидания в режиме активного использования (все числа натуральные, различные).

Типовой пример организации данных во входном файле
5
800 120
150 200
250 300
60 100
180 220
Пример организации данных приведён для пяти смартфонов.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемого файла.

data = []
with open('2624.txt') as file:
    next(file)
    id = 1
    for line in file:
        parts = line.strip().split()
        waiting_time = int(parts[0])
        active_time = int(parts[1])
        min_time = min(waiting_time, active_time)
        if min_time == waiting_time:
            type = "Ожидание"
        else:
            type = "Актив"

        phone = {
            "ID": id,
            "Ожидание": waiting_time,
            "Актив": active_time,
            "Минимальное": min_time,
            "Тип": type
        }
        data.append(phone)
        id += 1

data = sorted(data, key=lambda x: x["Минимальное"])

print(data[-1]["ID"])  # первый ответ

# разделяем на две группы
waiting_phones = [phone for phone in data if phone["Тип"] == "Ожидание"]
active_phones = [phone for phone in data if phone["Тип"] == "Актив"]

# сортируем каждую группу отдельно
waiting_phones_sorted = sorted(waiting_phones, key=lambda x: x["Ожидание"])
active_phones_sorted = sorted(active_phones, key=lambda x: -x["Актив"])

# объединяем
data_sorted = waiting_phones_sorted + active_phones_sorted

# ищем сколько ниже последнего в рейтинге (data[-1]["ID"])
for i, phone in enumerate(data_sorted):
    if phone["ID"] == data[-1]["ID"]:
        count_after = len(data_sorted) - i - 1
        print(count_after)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие