ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 26018. Типовые варианты

Дети играют в следующую игру. На бесконечном разлинованном на клетке листе введена декартова система координат, при этом клетки таковы, что их вершины находятся во всех точках плоскости, для которых обе координаты целочисленные. Есть некоторое количество бумажных квадратов, стороны которых имеют целочисленные длины. Дети помещают на плоскость эти квадраты (возможно, не все) так, что нижний левый угол каждого квадрата находится на биссектрисе координатного угла, идущей из третьей четверти в первую, и стороны квадратов параллельны осям координат. При этом положение каждого квадрата заранее определено.

Входной файл содержит сведения о размерах квадратов и их возможных положениях на плоскости. Для каждого квадрата указана целочисленная абсцисса положения его нижнего левого угла и длина стороны. Если при размещении на плоскости один квадрат накрывает другой, то дети должны оставить только один из них. Если стороны квадратов касаются, то можно оставить на плоскости оба квадрата. Определите максимальное количество квадратов, которое могут разместить на плоскости дети, и какова при этом максимально возможная величина модуля разности абсцисс положений левых нижних углов двух квадратов, наиболее удалённых от начала координат.

Входные данные.

В первой строке входного файла находится натуральное число N (N ≤ 1000) – количество квадратов. Следующие N строк содержат пары чисел, обозначающих абсциссу положения левого нижнего угла квадрата на плоскости и длину его стороны. Каждое из чисел целое, не превосходящее 1000. Запишите в ответе два числа: максимальное количество квадратов и максимальную величину модуля разности абсцисс положений левых нижних углов двух квадратов, наиболее удалённых от начала координат.

Типовой пример организации данных во входном файле

5
-20 120
90 20
147 43
150 30
120 20

При таких исходных данные можно поместить на плоскость максимум три квадрата, например, квадраты, описанные в файле под номерами 2, 3 и 5.
Максимальная величина модуля разности абсцисс положений левых нижних углов двух квадратов, наиболее удалённых от начала координат, составит 30, если на плоскость помещены квадраты 2, 4 и 5.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

data = []
with open('2618.txt') as file:
    next(file)
    for line in file:
        left_x, len_side = map(int, line.split())
        right_x = left_x + len_side
        data.append((left_x, right_x))

data = sorted(data, key=lambda x: x[1])

accepted_squares = [data[0]]
for left_x, right_x in data[1:]:
    if left_x >= accepted_squares[-1][1]:
        accepted_squares.append([left_x, right_x])

max_dist = 0
for left_x, right_x in data[1:]:
    if left_x >= accepted_squares[-2][1]:
        max_dist = max(max_dist, left_x - accepted_squares[-2][0])

print(len(accepted_squares), max_dist)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие