ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 26008. Основная волна

В магазине продаётся N товаров нескольких артикулов. Товары одного артикула имеют одинаковую цену. Учёт товаров ведётся поштучно, для каждой единицы товара известен её текущий статус (продана или нет). Товары разделены на две категории: дорогие и дешёвые. Дорогими считаются товары, цена на которые превышает среднюю цену (среднее арифметическое) всех товаров в базе данных магазина без учёта их текущего статуса, остальные товары считаются дешёвыми.

Лидером продаж называется товар с таким артикулом, наибольшее количество единиц которого продано. Лидер продаж выбирается среди дорогих товаров, а если продано одинаковое количество дорогих товаров с разными артикулами, лидером выбирается товар с наибольшей ценой. Если и таких товаров несколько, лидер продаж — тот из них, которого осталось меньше всего.

Найдите суммарную выручку магазина от реализации товара — лидера продаж, а также оставшееся количество товара этого артикула.

Входные данные

В первой строке входного файла находится число N — количество товаров в базе данных магазина (натуральное число, не превышающее 10 000). В каждой из следующих N строк находится три числа, разделённых пробелом: артикул товара (натуральное число, не превышающее 100 000), его цена (натуральное число, не превышающее 10 000) и статус (0, если товар уже продан, и 1, если ещё не продан).

Выходные данные

Два числа: сумма выручки от реализации товара — лидера продаж, а также количество товара этого артикула, оставшееся в наличии.

Типовой пример организации данных во входном файле
8
10 100 1
3 10 0
10 100 0
2 10 1
10 100 0
3 10 1
11 100 0
1 200 0

При таких исходных данных дорогими являются товары стоимостью 100 и 200 рублей. Больше всего было продано товара вида 10. В продаже остался один такой товар. Условию задачи удовлетворяет ответ 200 1.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемого файла.

import statistics
from itertools import groupby

data = []
with open('2608.txt') as file:
    N = int(file.readline())

    for line in file:
        parts = line.strip().split()
        tr = {
            "id"    : int(parts[0]),
            "price" : int(parts[1]),
            "status": int(parts[2])}

        data.append(tr)

# Среднее арифметическое
mean_price = statistics.mean([tr["price"] for tr in data])

data = sorted(data, key=lambda x: (-x["price"], x["id"], x["status"]))

filtered = [tr for tr in data if tr["price"] > mean_price]

# Группировка и агрегирование
aggregated = []
for pid, group in groupby(filtered, key=lambda x: x["id"]):
    group = list(group)
    price = group[0]["price"]
    total = len(group)
    sold = sum(1 for tr in group if tr["status"] == 0)
    left = total - sold
    aggregated.append((pid, price, total, sold, left))

# Сортировка по заданным критериям
aggregated.sort(key=lambda x: (-x[3], -x[1], x[4]))

# Вывод результата
ans = aggregated[0]
print(f'Выручка: {ans[1] * ans[3]}')
print(f'Товара осталось: {ans[4]}')
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие