ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 24031. Типовые варианты

Текстовый файл состоит из десятичных цифр и заглавных букв латинского алфавита.

Определите в прилагаемом файле последовательность из максимального количества идущих подряд символов, среди которых ровно 35 нечётных цифр и при этом начинающуюся с буквы S, не содержащую других букв S, кроме первой. В ответе запишите число – количество символов в найденной последовательности.

with open('2431.txt', 'r') as file:
    data = file.readline()

odds = {'1', '3', '5', '7', '9'}
n = len(data)
left = 0
count_odds = 0
max_len = 0

for right in range(n):
    if data[right] == "S":
        left = right
        count_odds = 0

    if data[right] in odds:
        count_odds += 1

    if data[left] == "S":
        has_other_S = any(c == "S" for c in data[left + 1:right + 1])
        if not has_other_S and count_odds == 35:
            current_len = right - left + 1
            if current_len > max_len:
                max_len = current_len

print(max_len)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие