ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 24013. Типовые варианты

Текстовый файл состоит не более чем из 106 символов арабских цифр (0, 1, 2, …, 9).

Определите максимальное количество идущих подряд цифр, расположенных в порядке невозрастания.

with open('2413.txt', 'r') as file:
    data = file.readline()

cnt = 1  # Количество цифр
max_len = 1  # Максимальная длина подстроки

for i in range(1, len(data)):
    if data[i] <= data [i-1]:
        cnt += 1
    else:
        cnt = 1
    max_len = max(cnt, max_len)

print(max_len)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие