ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17018. ЕГКР

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от -100 000 до 100 000 включительно.

Определите количество троек элементов последовательности, в которых ни один из трёх элементов не является четырёхзначным числом, а сумма элементов тройки больше максимального элемента последовательности, оканчивающегося на 30.

В ответе запишите количество найденных троек чисел, затем максимальную из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента последовательности.

with open('1718.txt') as f:
    data = list(map(int, f))

max_30 = max(i for i in data if i % 100 == 30)


def not_is_4(nums):
    return not any(1000 <= abs(n) <= 9999 for n in nums)


ans = []
for elements in zip(data, data[1:], data[2:]):

    if not_is_4(elements) and sum(elements) > max_30:
        ans.append(sum(elements))

print(len(ans), max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие