ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17011. Типовые варианты

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно.

Определите количество троек последовательности, в которых ни одно число не оканчивается на 3, а сумма квадратов чисел тройки больше максимального элемента последовательности.

В ответе запишите количество найденных троек, затем максимальную из сумм квадратов элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента последовательности.

with open('1711.txt') as f:
    data = list(map(int, f))

max_el = max(data)


def not_ends_with_three(arr):
    return not any(num % 10 == 3 for num in arr)


ans = []
for elements in zip(data, data[1:], data[2:]):
    sum_of_squares = sum(num ** 2 for num in elements)
    if not_ends_with_three(elements) and sum_of_squares > max_el:
        ans.append(sum_of_squares)

print(len(ans), min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие