ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 17004. Основная волна

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от –100 000 до 100 000 включительно.

Определите количество пар последовательности, в которых элементы не равны, а абсолютное значение их разности делится на минимальный положительный элемент последовательности, кратный 41.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

def cons(num):
    return num > 0 and num % 41 == 0


with open('1704.txt') as f:
    data = list(map(int, f))

min_el = min(num for num in data if cons(num))
answer = []

for x, y in zip(data, data[1:]):
    if x != y and abs(x - y) % min_el == 0:
        answer.append(x + y)

print(len(answer), max(answer))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие