ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15106. Типовая задача

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

Для какого наименьшего натурального числа A логическое выражение (ДЕЛ(x, 9) →  ¬ ДЕЛ(x, 6)) ∨ (x + A ≥ 100) истинно (т.е. принимает значение 1) при любом целом положительном значении переменной x?

def f(x, A):
    return ((x % 9 == 0) <= (x % 6 != 0)) or (x + A >= 100)


for A in range(1, 500):
    if all(f(x, A) for x in range(1, 500)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие